Attention - Proaxive 1.6.0 est actuellement en version bêta, je déconseille de l'utiliser en production, veuillez attendre la première version stable.

Préparer son serveur/hébergement afin d'accueillir Proaxive

Proaxive est développé en PHP et utilise une base de données MySQL pour fonctionner.

Votre version de PHP doit être au minimum en 7.4, l'application fonctionne également sous PHP 8.x.

Vous devez également installer et activer des extensions PHP :

  • php-intl
  • php-xml

Votre version de MySQL doit être au minimum en 5.X

Un accès SSH est obligatoire pour installer les paquets qu'a besoin Proaxive.

Vous devez avoir Composer sur votre serveur/hébergement.

Pour que les mises à jour soient le plus simple possible, je vous conseil également d'installer Git sur votre hébergement.

Tous les paquets dont dépend Proaxive s'installe en une ligne de commande.

Liens utiles

Se connecter en SSH
Installer Composer sous Linux
Installer Composer sous Windows
Installer Git
php-intl
php-xml